Child pages
  • Catalogs and MAF
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 2 Next »

Stack requirements:

The general philosophy LSST software stack is that some python dependencies are so ubiquitous in scientific computing environments that it is more difficult for users to provide new versions than it is to supply them with the stack.  The simulations framework relies on the following dependencies that are not part of the LSST stack:

  • python 2.7
  • numpy
  • scipy
  • matplotlib
  • sqlalchemy

The recommended install instructions will provide these dependencies for you through an Anaconda distribution.  

Recommended Installation Instructions

The recommended (simplest) approach is to use the newest W14 LSST software stack, and use the LSST-provided version of anaconda python. (See here if you want to use your own python). 

1. Start by installing the necessary parts of the LSST software stack and the LSST-installed anaconda. 

In these instructions we assume you are installing in ~/lsst, however the install directory can be any place in the file system, including a place visible to all users.

mkdir ~/lsst
cd ~/lsst
curl -O http://sw.lsstcorp.org/eupspkg/newinstall.sh
bash newinstall.sh

Choose yes when prompted to install Anaconda.  Choose yes when prompted to install git.  These packages will not interfere with your system installed versions.

 2. Set up the environment and install the simulations code and data.

Source the appropriate shell script and use eups (and here for more info) to install the software and data. 

source ~/lsst/loadLSST.csh 
eups distrib install lsst_sims -t sims

This will install all packages currently in the catalogs simulations framework and metrics analysis framework and all dependencies.  Currently the complete list of installed packages is:

 

  • base – LSST import utilities
  • boost– Third party C++ package
  • cfitsio– FITSIO I/O library
  • daf_base – LSST data access framework 
  • doxygen– Documentation suite
  • freetds– OpenSource implementation for Tabular Data Streams (needed by pymssql)
  • healpy– Python bindings for HealPix 
  • palpy– Python binidings for PAL (Positional Astronomy Library)
  • pex_config – LSST configuration package
  • pex_exceptions – LSST exception handling package.
  • pex_policy – Another LSST configuration package
  • pyephem– Ephemeris generation code
  • pyfits– Python bindings for interacting with FITS files
  • pykg_config– Pure python implementation of pkg_config needed to install healpy on Mac OSX
  • pymssql– Python bindings for talking to MS-SqlServer databases (needed to access UW base catalogs)
  • scons– Software construction  tool
  • sconsUtils – LSST utilities for scons
  • sims_catalogs_generation – Code for querying databases for catalog data
  • sims_catalogs_measures – Code for constructing observed catalogs including variable photometry and astrometry
  • sims_dustmaps – SFD dust maps
  • sims_maf – Metrics Analysis Framework
  • sims_sed_library – Library of SED data for simulated catalogs
  • swig– Library for auto-generating python bindings for C++ code
  • throughputs – Nominal throughput curves for SDSS and LSST systems
  • utils – LSST utilities package

Any of the above packages and all its dependencies can be installed by replacing lsst_sims with the appropriate package name (e.g. sims_maf) in the above code snippet.  Installation is now complete.  See package specific pages for documentation.

 

 

 

 

 

  • No labels