Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

THIS PAGE IS OUT OF DATE.  ALL GEN3 MIDDLEWARE CODE IS NOW ON MASTER, SO THERE ARE NO SPECIAL INSTRUCTIONS TO SET IT UP.  THE gen3-middleware BRANCH HAS BEEN RETIRED AND SHOULD NOT BE USED.


Prior to full integration with the rest of the codebase, Gen3 Middleware work is being done on different branches in different packages.  This page tracks which packages use which branches and which weekly versions are expected to be compatible.

...

  • Gen3 work is merged to master, as no non-Gen3 version exists (daf_butlerpipe_supertask).
  • Gen3 work is merged to the gen3-middleware branch, which is rebased periodically on master to avoid diverging from the main codebase.
  • Gen3 work has been merged to master, as it is either considered stable or non-intrusive.
  • No Gen3 specializations exist; at least one weekly tag is guaranteed to be compatible with the Gen3 stack.

Packages

NameBranch/TagNotes
daf_butlermasterNo non-Gen3 code exists.
pipe_supertaskmasterNo non-Gen3 code exists.
skymapgen3-middleware
obs_subarugen3-middleware
ci_hscgen3-middleware
(all others)w.2018.22


Setting up the Gen3 Middleware Stack

...